Benutzer-Werkzeuge

Webseiten-Werkzeuge


 [[anwenderwiki:classroom_management:maussk-vnc]] 

Installation von VNC auf Ubuntu 18.04 bionic

Empfehlung: VNC als Startprogramm beim User-Login installieren, funktioniert gut, man kann sich aber damit über VNC nicht anmelden.

Probleme:

  • falls VNC schon vor einem Login verfügbar sein sollte, muss ein systemd-Service installiert werden
  • der Displaymanager gdm schaltet beim Login auf ein anderes Display um, so dass man über VNC nur ein schwarzes Bild sieht

siehe auch → VNC bei Ubuntu 12.04 mit lightdm

Installation aus den Paketquellen

# apt-get update
# apt-get install x11vnc
# x11vnc -storepasswd /etc/x11vnc.pass
# chmod 644 /etc/x11vnc.pass

Das Passwort wird dabei als Hash in der Datei /etc/x11vnc.pass abgelegt. Diese Datei muss für alle User lesbar sein.

gdm: VNC nach User-login starten

Bei „Startprogramme“ folgenden Eintrag hinzufügen:

Name: VNC
Befehl: /usr/bin/x11vnc -auth guess -forever -loop -noxdamage -repeat -rfbauth /etc/x11vnc.pass -rfbport 4711 -shared
Kommentar: VNC-Server    

lightdm: VNC als Service beim Booten konfigurieren

Zunächst eine neue Datei /lib/systemd/system/x11vnc.service anlegen mit folgendem Inhalt, auf Groß/Kleinschreibung der Tags achten.

[Unit]
Description=Startet X11VNC beim Booten
After=multi-user.target

[Service]
Type=forking
ExecStart=/usr/bin/x11vnc -xkb -auth /var/run/lightdm/root/:0 -noxrecord -noxfixes -noxdamage -rfbauth /etc/x11vnc.pass -forever -bg -rfbport 4711
ExecStop=/usr/bin/killall x11vnc

[Install]
WantedBy=multi-user.target

Dann:

# systemctl enable x11vnc.service
# systemctl daemon-reload
# systemctl start x11vnc.service

Jetzt den Ubuntu-Client neu booten.

gdm: VNC als Service beim Booten konfigurieren

Den obigen Start-Befehl abändern, so dass das Display des gdm-Users verwendet wird. Wayland muss disabled sein (s.u.).

... 
ExecStart=/usr/bin/x11vnc -xkb -auth /run/user/121/gdm/Xauthority -noxrecord -noxfixes -noxdamage -rfbauth /etc/x11vnc.pass -forever -bg -rfbport 4711
...

Problem: Nach dem Login wechselt gdm das Display und VNC zeigt nur einen schwarzen Bildschirm.

Disable wayland

Beim Abschalten von wayland funktioniert der mausdaemon auf dem Client nicht mehr korrekt, da sich die Display-Nummern ändern!

Datei /etc/gdm3/custom.conf bearbeiten:

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false
 [[anwenderwiki:classroom_management:maussk-vnc]] anwenderwiki/classroom_management/maussk-vnc.txt · Zuletzt geändert: 2020/02/02 22:30 von martin.res