Benutzer-Werkzeuge

Webseiten-Werkzeuge


 [[anwenderwiki:virtualisierung:virtualisierung:xenserver:xen-server-lacp-bonds:start]] 

Einrichtung eines NIC LACP Bonds auf XenServer und einem Cisco 2960 Switch

Voraussetzung:

  • Server mit installiertem XenServer 6.5/7 (Hypervisor), der als Pool-Master definiert wurde.
  • ausreichend Netzwerkkarten pro Server
  • Netzinfrastruktur, die VLANs (802.1q) unterstützt
  • Switch, an den die Bond-NICs angeschlossen werden, auf dem Link Aggregation konfiguriert werden kann.

Gegeben:

  • Server
  • 2x CPU Intel XEON E52407v2 (Ivy Bridge)
  • 1x Quad NIC Karte,
  • 1x interne NIC,
  • 1x iSCSI HBA,
  • XenServer 6.5 mit SPs installiert und als Pool-Master definiert
  • 1x Cisco 2950s-24TS Switch, mit IOS 15

Vorgehen:

  • Festlegen der Aufteilung der NICs (PIFs - Physical Interfaces): 3 Ports der Quad-Karte als Bond für VM-Traffic, 1 Port auf DSL-Router, 1 Port (intern) als Management NIC
  • Quad NIC → NIC 2,3,4 (1.-3. Port) auf z.B. Ports 2, 2, 4 patchen, NIC 5 auf DSL-Router patchen
  • XenServer: Auf Konsole die Bond-Schnittstelle einrichten, VLANs einrichten, BOND-Interface (UUID) den VLANs zuordnen, VMs NICs den VLAN Netzwerken zuordnen
  • Cisco Switch: Ports als PortChannel definieren, die als Trunk arbeiten

XenServer konfigurieren

Zuerst sollte auf XenServer CLI gewechselt werden oder direkt auf die Konsole via SSH zugegriffen werden. Es sind zunächst alle Informationen zu den NICs zu ermitteln, die für die weitere Konfiguration benötigt werden (NIC-Bezeichnung, UUID).

xe pif-list

Mit diesem Befehl werden die benötigten Infos aufgelistet. Hier müssen mithilfe des Device-Eintrags jene NICs identifiziert werden, die als BOND konfiguriert werden sollen. Es sind die Bezeichnung (z.B. eth2, eth3, eth4) und die zugehörige UUID zu notieren. Die UUIDs werden später für die eindeutige Zuordnung der PIFs zum neu zu erstellenden BOND benötigt.

Sollte festgestellt werden, dass die Bezeichnungen der NICs von den gewünschten abweichen, so kann dies ggf. manuell mit dem Befehl interface-rename korrigiert werden.

LACP Netwzwerk BOND einrichten

Zunächst muss ein BOND-Netzwerk angelegt werden.

# xe network-create name-label=”Server1-LACP-Bond”

Nach Absetzen des Befehls erscheint die UUID des neu eingerichteten Netzwerks. Ggf. kann diese aber auch wieder mit nachstehendem Befehl ermittelt werden.

# xe network-list name-label=”Server1-LACP-Bond”

Diese UUID wird später benötigt, um diesem Netzwerk die gewünschten PIFs zuordnen zu können.

Es wird nun mit folgendem Befehl der LACP Bond mit den gewünschten PIFs angelegt:

# xe bond-create mode=lacp network-uuid=<UUID-Server1-LACP-Bond> pif-uuids=<UUID-eth2>,<UUID-eth3>,<UUID-eth4>

Nach Anlegen des BONDs erscheint dessen UUID. Zur Kontrolle, ob der BOND angelegt wurde kann folgender Befehl genutzt werden;

# xe bond-list

Cisco Switch: Port Channel definieren

Als Gegenstück zu den drei Netzwerkkarten des XenServers, die als BOND konfiguriert sind, wird auf dem Switch ebenfalls ein LACP (Port Channel) benötigt, der als Trunk konfiguriert ist.

  1. Zuerst ist ein Port Channel zu definieren
  2. für den Port-Channel sind weitere Einstellungen vorzunehmen
  3. es sind die Ports zu definieren, die dem Port-Channel hinzugefügt werden
  4. vlan 10 wird hier für grün, vlan 20 für blau genutzt - andere VLANS je nach eigener VLAN Konfiguration

Port Channel definieren:

configure terminal
  interface Port-channel2
  description Trunk fuer Xen Server mit Ports 2-4
  switchport trunk allowed vlan 10,20,30,100
  switchport mode trunk
  switchport nonegotiate
  storm-control broadcast level 50.00

Ports dem Port-Channel hinzufügen:

configure terminal
  interface range GigabitEthernet 1/0/2-4
  description trunk ports fuer xenServer x3630m4
  switchport trunk allowed vlan 10,20,30,100
  switchport mode trunk
  switchport nonegotiate
  storm-control broadcast level 50.00
  no cdp enable
  spanning-tree portfast disable
  channel-group 2 mode auto
  no shutdown

Als LACP Methode wurde hier auto gewählt. Wenn ein PAgP Gerät gefunden wird, arbeitet der Port als passiver Port.

XenServer: VMs den VLANs zuordnen

Die VMs der linuxmuster.net 6.2 sind schließlich den korrekten VLANs zuzuordnen:

Dies lässt sich anhand des nachstehenden Beispiels nachvollziehen:

lmn62.ipfire Device 0: VLAN20 - blaues Netz Device 1: RED - rotes Netz ohne VLAN - Tag Verbindung zu DSL-Router Device 2: VLAN10 - gruenes Netz
 [[anwenderwiki:virtualisierung:virtualisierung:xenserver:xen-server-lacp-bonds:start]] anwenderwiki/virtualisierung/virtualisierung/xenserver/xen-server-lacp-bonds/start.txt · Zuletzt geändert: 2016/08/16 11:13 (Externe Bearbeitung)