Benutzer-Werkzeuge

Webseiten-Werkzeuge


 [[anwenderwiki:moodle:install-paket-lm]] 

Moodle 2.x aus einem Zusatz-Repo für Ubuntu 12.04 LTS installieren

Die hier beschriebene Vorgehensweise dient zur Neuinstallation von Moodle. Falls eine ältere Version von Moodle aktualisiert werden muss, ist unter migration_1.9.x_2.4.x eine Anleitung mit Hilfe eines Migrationspakets zu finden.

Zur Zeit ist die Version Moodle 2.6.1 aktuell. Sie wird von mir weiterhin aktualisiert.

Neuigkeiten zu Moodle sind in diesem Forum zu finden: Linuxmuster.net Moodle

Das Paket befindet sich in meinem Repo für Ubuntu. Es folgen Hinweise zur Verwendung:

Die URL lautet: http://download.opensuse.org/repositories/home:/fschuett/xUbuntu_12.04

Folgende Datei muss erstellt werden:

/etc/apt/sources.list.d/linuxmuster-moodle.list

Inhalt:

deb http://download.opensuse.org/repositories/home:/fschuett/xUbuntu_12.04 /
deb-src http://download.opensuse.org/repositories/home:/fschuett/xUbuntu_12.04 /

Hinweis: Ein Leerzeichen befindet sich vor dem letzten Schrägstrich.

Der Schlüssel muss importiert werden:

wget http://download.opensuse.org/repositories/home:/fschuett/xUbuntu_12.04/Release.key -O - | apt-key add -

Danach kann das Paket linuxmuster-moodle 1) z.B. über aptitude installiert werden.

aptitude update
aptitude install linuxmuster-moodle

Während der Installation wird das Passwort für den Benutzer wwwadmin erfragt.

Existierende Moodle-Daten werden nicht überschrieben.

Das Moodle ist dann unter https://servername/moodle verfügbar.

Die Konfig-Dateien liegen unter /etc/moodle/.
Die Moodle-Daten unter /var/lib/moodle/.
Die Moodle-php-Scripte unter /usr/share/moodle/.

Nach der Anmeldung als wwwadmin kann man unter Website-Administration → Server → Serverkonfiguration den Installationsstatus abrufen.

Ein Upgrade auf Moodle 2.5 geht nur von Moodle >2.2!!!
Ein 1.9.x-Moodle und dessen Datenbank ist deshalb unbrauchbar, man sollte die DB vorher löschen:

dropdb -U postgres moodle

Ggf. fehlt noch ein optionales Paket, das man nachinstallieren kann:

aptitude install php5-intl
/etc/init.d/apache2 restart
1)
zur Zeit in der Version 2.6.1
 [[anwenderwiki:moodle:install-paket-lm]] anwenderwiki/moodle/install-paket-lm.txt · Zuletzt geändert: 2014/02/18 18:35 (Externe Bearbeitung)