Benutzer-Werkzeuge

Webseiten-Werkzeuge


 [[anwenderwiki:linuxclient:xenialmate]] 

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

anwenderwiki:linuxclient:xenialmate [2017/03/01 11:23] (aktuell)
Zeile 1: Zeile 1:
 +{{tag> }}
  
 +====== Installationslogbuch Ubuntu (Mate) 16.04 ======
 +  * Partitionierung von LINBO
 +  * start unter kvm: prozessor qemu64
 +  * Boot von ISO 02.12.15 -> Install -> Deutsch -> Ja (updates), Ja(mp3) -> "etwas anderes (selbst parti)"​
 +    * Partitionierung:​ vda1 als / als ext4, vda2 als swap als swap
 +  * Standort Berlin -> Deutsch (ohne Akzenttasten) ​
 +  * Linuxadmin, dummyclient,​ linuxadmin:​linuxmuster,​ normal anmelden
 +
 +===== Image erstellen =====
 +<​code>​
 +/​root/​make_image_public.sh
 +</​code>​
 +
 +===== postsync =====
 +<​code>​
 +./​etc/​linuxmuster-client/​server.network.settings
 +./​root/​.ssh/​authorized_keys
 +./​postsync.d/​04-generate-hosts
 +./​postsync.d/​02-patch-sshd-config
 +./​postsync.d/​03-fix-fstab
 +./​postsync.d/​00-fix-initrd
 +</​code>​
 +====== linuxmuster-client Pakete ======
 +<​code>​
 +# wget http://​pkg.linuxmuster.net/​linuxmuster.net.key ​
 +# apt-key add linuxmuster.net.key
 +OK
 +# echo "deb http://​pkg.linuxmuster.net/​ trusty/"​ >>/​etc/​apt/​sources.list.d/​linuxmuster-client.list
 +# apt-get update
 +# apt-get install linuxmuster-client-auth
 +
 +</​code>​
 +Konfiguration wie hier [[:​dokumentation:​handbuch:​clients:​linuxmuster-client-auth]]
 +
 +<​code>​
 +# apt-get install linuxmuster-client-shares
 +fails, patch:
 +
 +# nano /​var/​lib/​dpkg/​info/​linuxmuster-client-shares.postinst
 +
 +       # determine client ip
 +        #​clientip=`ifconfig ​ | grep 255.240.0.0 | awk '​{print $2}' | awk -F: '​{print $2}'`
 +        clientname=$HOSTNAME
 +        #​clientname=`host $clientip | awk '​{print $5}' | cut -d. -f1`
 +        clientip=`gethostip -d $HOSTNAME`
 +        # determine servername
 +        fqsn=`host -v $clientip | grep -A1 AUTHORITY | grep in.addr | awk '​{print $5}'`
 +        # determine serverip
 +        serverip=`host -t A $fqsn | awk '​{print $4}'`
 +
 +# dpkg-reconfigure linuxmuster-client-shares
 +</​code>​
 +
 +===== Profile funktioniert fast: =====
 +<​code>​
 +# apt-get install linuxmuster-client-profile
 +</​code>​
 +K.A. ob notwendig: "​user"​ aufgenommen in ''​sambashare''​ Gruppe in ''/​etc/​security/​groups.conf''​
 +  * sshplus funktioniert nicht, wenn man nicht zwei Pakete nachinstalliert:​
 +<​code>​ # apt install python-notify python-appindicator </​code>​
 +
 +extras works: <​code>​
 +# aptitude install linuxmuster-client-extras
 +# linuxmuster-client-extras-setup --type login --on /​usr/​bin/​create-desktop-icons
 +# linuxmuster-client-extras-setup --type login --on /​usr/​bin/​xhost-root
 +</​code>​
 +check-shutdown einkommentiert in ''/​etc/​cron.d/​linuxmuster-client-extras''​
 +
 +sudoers works: <​code>​
 +# apt install linuxmuster-client-sudoers
 +</​code>​
 +
 +====== Pakete regulär nachinstallieren ======
 +Beim aptitude Befehl immer mit "​-R":​
 +<​code>​
 +# apt-get install aptitude
 +# for i in $( echo "
 +openssh-server
 +blender
 +gimp gimp-help-de
 +openjdk-7-jdk
 +chromium-browser chromium-codecs-ffmpeg-extra
 +vnc4server
 +wxmaxima gchempaint gnuplot5-x11
 +scratch
 +audacity
 +inkscape
 +minitube
 +davfs2
 +mc
 +ssh-askpass-gnome
 +pdfshuffler
 +stellarium
 +conky
 +python-odf-tools
 +dos2unix
 +virtualbox
 +youtube-dl libav-tools
 +freecad
 +pinta
 +rosegarden ladspa-sdk jackd qjackctl sndfile-tools wavpack amb-plugins autotalent blepvco bs2b-ladspa csladspa invada-studio-plugins-ladspa fil-plugins mcp-plugins rev-plugins ste-plugins swh-plugins tap-plugins vco-plugins wah-plugins
 +") ; do aptitude -y -R install $i ; done
 +</​code>​
 +===== Pakete installieren über spezielle Wege =====
 +  * Für Leoclient2 Ext-pack von virtualbox runterladen <​code>​
 +# aptitude install ​ virtualbox-ext-pack virtualbox-qt
 +</​code>​ erfordert abnicken der PUEL-licence,​ dann leoclient: <​code>​
 +# aptitude install libglib-perl libgtk2-perl leoclient2-leovirtstarter-client leoclient2-vm-printer linuxmuster-client-sudoers
 +</​code>​ Dann muss man noch der Anleitung folgend ein paar wichtige Skripte installieren http://​docs.linuxmuster.net/​de/​latest/​howtos/​leoclient2/​index.html
 +  * Oracle Java 8 <​code>​
 +# apt-add-repository -y ppa:​webupd8team/​java
 +# echo oracle-java8-installer shared/​accepted-oracle-license-v1-1 select true | sudo /​usr/​bin/​debconf-set-selections
 +# aptitude -y -R install oracle-java8-installer oracle-java8-set-default
 +</​code>​
 +  * BlueJ Latest Version: http://​www.bluej.org/​versions.html <​code>​
 +# wget http://​www.bluej.org/​download/​files/​bluej-316.deb
 +# dpkg -i bluej-316.deb
 +# rm bluej-316.deb
 +# apt-add-repository -y ppa:​webupd8team/​java
 +# echo oracle-java8-installer shared/​accepted-oracle-license-v1-1 select true | sudo /​usr/​bin/​debconf-set-selections
 +# aptitude -y -R install oracle-java8-installer oracle-java8-set-default
 +</​code>​
 +  * GReenfoot latest version: http://​www.greenfoot.org/​download <​code>​
 +# wget http://​www.greenfoot.org/​download/​files/​Greenfoot-linux-302.deb
 +# dpkg -i Greenfoot-linux-302.deb
 +# rm Greenfoot-linux-302.deb
 +</​code>​
 +  * LibreCAD <​code>​
 +# apt-add-repository ppa:​librecad-dev/​librecad-daily -y
 +# echo "deb http://​ppa.launchpad.net/​librecad-dev/​librecad-daily/​ubuntu xenial main" > /​etc/​apt/​sources.list.d/​librecad-dev-ubuntu-librecad-daily-xenial.list
 +# apt-get update
 +# aptitude -R install librecad
 +</​code>​
 +  * Geogebra5 <​code>​
 +# wget http://​www.geogebra.net/​linux/​office@geogebra.org.gpg.key -O - | apt-key add -
 +# apt-add-repository -y 'deb http://​www.geogebra.net/​linux/​ stable main'
 +# apt-get update
 +# aptitude -R install geogebra5
 +</​code>​
 +  * Owncloud client <​code>​
 +# wget http://​download.opensuse.org/​repositories/​isv:​ownCloud:​desktop/​Ubuntu_16.04/​Release.key -O - | apt-key add -
 +# echo 'deb http://​download.opensuse.org/​repositories/​isv:/​ownCloud:/​desktop/​Ubuntu_16.04/​ /' >> /​etc/​apt/​sources.list.d/​owncloud-client.list
 +# apt-get update
 +# aptitude -R install owncloud-client
 +</​code>​
 +  * Eclipse 3.8: Das in Ubuntu erhältliche 3.8 eclipse ist ok, wenn auch nicht mehr supported?, aber ohne deutschsprachige Unterstützung,​ diese kann man zwar nachladen, aber das wird zunächst im Home-Verzeichnis des Users abgelegt (zu groß). -> http://​archive.eclipse.org/​technology/​babel/​update-site/​R0.12.1/​babel-R0.12.1-juno.zip <​code>​
 +# aptitude -R install eclipse-jdt ​
 +# aptitude -R install eclipse-wtp-webtools eclipse-pydev eclipse-cdt
 +</​code>​ Ersetzt durch eclipse Luna in /opt -> <​code>​
 +# apt purge eclipse-platform eclipse-cdt-jni eclipse-rcp eclipse-platform-data
 +# apt --purge autoremove
 +</​code>​
 +  * ttf-mscorefonts ohne Nachfrage zur EULA <​code>​
 +# echo ttf-mscorefonts-installer msttcorefonts/​accepted-mscorefonts-eula select true | sudo debconf-set-selections
 +# DEBIAN_FRONTEND=noninteractive aptitude -y install ttf-mscorefonts-installer
 +</​code>​
 +  * Weitere Fonts: z.B. alle, die durch "​edubuntu-fonts"​ (ohne -R) hinzugezogen werden <​code>​
 +# aptitude install edubuntu-fonts
 +# aptitude install fonts-crosextra-carlito
 +# aptitude install fonts-crosextra-caladea
 +</​code>​
 +  * Google Chrome <​code>​
 +# wget -q -O - https://​dl.google.com/​linux/​linux_signing_key.pub | sudo apt-key add -
 +# wget https://​dl.google.com/​linux/​direct/​google-chrome-stable_current_amd64.deb
 +# dpkg -i google-chrome-stable_current_amd64.deb
 +</​code>​
 +  * Gantt-project <​code>​
 +# wget http://​www.ganttproject.biz/​dl/​2.7.2/​lin -O gantt-project.deb
 +# dpkg -i gantt-project.deb
 +# sed "/​OnlyShow/​d"​ /​usr/​share/​applications/​ganttproject.desktop -i
 +</​code>​
 +  * Vektoris3D Plus (shareware) <​code>​
 +# wget http://​produkte.kapieren.de/​mediafiles/​downloads/​vektoris3d25plus/​V3D25Plus_unix_Setup_20111110.sh
 +... tut nicht unter 64bit
 +</​code>​
 +  * DVD CSS - man muss wissen, ob man die Berechtigung für die CSS-decryption hat <​code>​
 +# aptitude -R install libdvd-pkg
 +# sudo dpkg-reconfigure libdvd-pkg
 +</​code>​
 +  * Filius - Informatik Netzwerksimulation <​code>​
 +# wget http://​www.lernsoftware-filius.de/​downloads/​filius_1.7.2_all.deb
 +# dpkg -i filius_1.7.2_all.deb </​code>​
 +  * Buttonbar - Startbuttons auf dem Desktop <​code>​
 +# wget http://​www.linuxmuster.net/​wiki/​_media/​anwenderwiki:​linuxclient:​buttonbar-0.20-x86_64.tar.bz2 -O buttonbar-0.20-x86_64.tar.bz2
 +# tar -xjf buttonbar-0.20-x86_64.tar.bz2 -C /​opt/​buttonbar/​
 +# mv /​opt/​buttonbar/​buttonbar.files/​startbuttonbar /​opt/​buttonbar/​
 +# mv /​opt/​buttonbar/​buttonbar.files/​buttonbar.cfg ​ /​opt/​buttonbar/​
 +# mv /​opt/​buttonbar/​buttonbar.files/​Bilder /​opt/​buttonbar/​
 +# chmod 755 /​opt/​buttonbar/​startbuttonbar
 +# chmod 644 /​opt/​buttonbar/​buttonbar.cfg
 +# chmod 755 /​opt/​buttonbar/​Bilder
 +# chmod 655 /​opt/​buttonbar/​Bilder/​*
 +</​code>​
 +  * appinventor:​ App emulator und aistarter: <​code>​
 +# cd /opt
 +# wget http://​appinv.us/​aisetup_linux_deb
 +# wget http://​diymakers.es/​wp-content/​uploads/​2014/​02/​google-app-inventor-icon-300x297.jpg
 +# mv aisetup_linux_deb appinventor2-setup_2.3_all.deb
 +# dpkg -i appinventor2-setup_2.3_all.deb
 +# aptitude install zlib1g:i386 libstdc++6:​i386
 +# echo << EOF > appinventor-ai.desktop
 +[Desktop Entry]
 +Version=1.0
 +Encoding=UTF-8
 +Name=Appinventor Starter
 +GenericName=Appinventor Starter
 +Comment=Wird von Appinventor Webprogramm benötigt
 +Type=Application
 +Exec=/​usr/​google/​appinventor/​commands-for-Appinventor/​aiStarter
 +Icon=/​opt/​google-app-inventor-icon-300x297.jpg
 +Terminal=true
 +Categories=Education;​
 +# cp appinventor-ai.desktop /​usr/​share/​applications/​appinventor-ai.desktop
 +</​code>​
 +====== Pakete deinstallieren ======
 +Pakete die hier nicht sinnvoll erscheinen
 +  * Fonts <​code>​
 +# apt purge fonts-noto-cjk (ubuntu-mate-core) (ubuntu-mate-desktop)
 +# aptitude purge fonts-tibetan-machine fonts-takao-pgothic fonts-sil-padauk fonts-kacst fonts-kacst-one ​ fonts-khmeros-core fonts-lao fonts-lklug-sinhala fonts-lohit-guru fonts-nanum fonts-sil-abyssinica
 +# aptitude purge fonts-thai-tlwg fonts-tlwg-garuda fonts-tlwg-kinnari fonts-tlwg-laksaman ​ fonts-tlwg-loma fonts-tlwg-mono fonts-tlwg-norasi fonts-tlwg-purisa fonts-tlwg-sawasdee fonts-tlwg-typewriter fonts-tlwg-typist fonts-tlwg-typo fonts-tlwg-umpush fonts-tlwg-waree
 +</​code>​
 +
 +  * rhythmbox <​code>​
 +# apt purge rhythmbox </​code>​
 +  * update-notifier <​code>​
 +# aptitude purge update-notifier ubuntu-release-upgrader-gtk update-manager ubuntu-mate-welcome </​code>​
 +  * ntp ist dann überflüssig,​ wenn man mit ntpdate arbeiten kann <​code>​
 +# aptitude purge ntp
 +</​code>​
 +====== Pakete die manuellen Eingriff brauchen (TODO) ======
 +  * linuxmuster-client-veracrypt
 +  * Eclipse 4.5 (Mars) funktionierte bei mir nicht
 +  * Eclipse 4.6 (Neon) noch nicht stabil, funktioniert,​ aber es gibt keine deutschsprachige Unterstützung
 +  * Eclipse 4.4 (Luna) funktioniert,​ aber nicht mit deutschsprachiger Unterstützung
 +  * FreeCAD zieht python und 250 MB nach sich.
 +  * winecfg erstellen: winetricks aktuell herunterladen,​ weil download von MS nicht mehr funktioniert,​ siehe https://​github.com/​Winetricks/​winetricks/​issues/​600,​ Bsp Adobe Reader, nach Anleitung https://​appdb.winehq.org/​objectManager.php?​sClass=version&​iId=27093<​code>​
 +# wget https://​raw.githubusercontent.com/​Winetricks/​winetricks/​master/​src/​winetricks
 +# mkdir /home/wine
 +# chown tmpadmin /home/wine
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 DISPLAY=:0 wine '​wineboot'​
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 DISPLAY=:0 ./​winetricks atmlib
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 DISPLAY=:0 ./​winetricks riched20
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 DISPLAY=:0 ./​winetricks wsh57
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 DISPLAY=:0 ./​winetricks mspatcha
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 DISPLAY=:0 ./​winetricks win7
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 DISPLAY=:0 wine /​tmp/​AdbeRdr11010_de_DE.exe
 +Installationspunkt -> Weiter
 +Updates: keine -> Weiter
 +-> Fertigstellen
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 DISPLAY=:0 ./​winetricks winxp
 +# env WINEPREFIX=/​home/​wine/​.wine32 WINEARCH=win32 wine C:​\\Program\ Files\\Adobe\\Reader\ 11.0\\Reader\\AcroRd32.exe
 +</​code>​ läuft zwar, leider stürzt es immer beim Versuch zu Drucken ab. Ebenso, wenn man wine v1.9.7 von hier: https://​wiki.winehq.org/​Ubuntu installiert,​ ebenso, wenn man schriftarten "​allfonts"​ und "​ppv"​ vorher (unter wine1.8) installiert.
 +  * MS Office 2007 in wine: SaveAsPDFandXPS extension <​code>​
 +https://​download.microsoft.com/​download/​d/​9/​b/​d9b31a37-e89d-4ae1-9456-94183ddaa2fa/​SaveAsPDFandXPS.exe
 +</​code>​
 +===== Repositories =====
 +Standard-Repositories anpassen:
 +<code bash /​etc/​apt/​sources.list>​
 +deb http://​nl.archive.ubuntu.com/​ubuntu/​ xenial main restricted
 +#deb-src http://​nl.archive.ubuntu.com/​ubuntu/​ xenial main restricted
 +
 +deb http://​nl.archive.ubuntu.com/​ubuntu/​ xenial-updates main restricted
 +#deb-src http://​nl.archive.ubuntu.com/​ubuntu/​ xenial-updates main restricted
 +
 +deb http://​nl.archive.ubuntu.com/​ubuntu/​ xenial universe
 +#deb-src http://​nl.archive.ubuntu.com/​ubuntu/​ xenial universe
 +deb http://​nl.archive.ubuntu.com/​ubuntu/​ xenial-updates universe
 +#deb-src http://​nl.archive.ubuntu.com/​ubuntu/​ xenial-updates universe
 +
 +deb http://​nl.archive.ubuntu.com/​ubuntu/​ xenial multiverse
 +#deb-src http://​nl.archive.ubuntu.com/​ubuntu/​ xenial multiverse
 +deb http://​nl.archive.ubuntu.com/​ubuntu/​ xenial-updates multiverse
 +#deb-src http://​nl.archive.ubuntu.com/​ubuntu/​ xenial-updates multiverse
 +
 +deb http://​nl.archive.ubuntu.com/​ubuntu/​ xenial-backports main restricted universe multiverse
 +#deb-src http://​nl.archive.ubuntu.com/​ubuntu/​ xenial-backports main restricted universe multiverse
 +
 +deb http://​security.ubuntu.com/​ubuntu xenial-security main restricted
 +#deb-src http://​security.ubuntu.com/​ubuntu xenial-security main restricted
 +deb http://​security.ubuntu.com/​ubuntu xenial-security universe
 +#deb-src http://​security.ubuntu.com/​ubuntu xenial-security universe
 +deb http://​security.ubuntu.com/​ubuntu xenial-security multiverse
 +#deb-src http://​security.ubuntu.com/​ubuntu xenial-security multiverse
 +
 +deb http://​archive.canonical.com/​ubuntu xenial partner
 +#deb-src http://​archive.canonical.com/​ubuntu xenial partner
 +</​code>​
 +
 +<​code>​
 +# apt-add-repository -y ppa:​ubuntu-wine/​ppa ​
 +# apt-add-repository -y ppa:​webupd8team/​java
 +
 +</​code>​
 +  * Wenn man Virtualbox in aktuellerer Version braucht, benötigt man Oracles Repositories <​code>​
 +# echo "deb http://​download.virtualbox.org/​virtualbox/​debian xenial contrib"​ >> /​etc/​apt/​sources.list.d/​virtualbox.list
 +# wget -q https://​www.virtualbox.org/​download/​oracle_vbox_2016.asc -O- | sudo apt-key add -
 +</​code>​
 +
 +====== Programme/​Skripten manuell ======
 +<​code>​
 +# wget http://​www.linuxmuster.net/​wiki/​_media/​anwenderwiki:​server:​purge-old-kernels.tgz ​ -O purge-old-kernels.tgz
 +# tar -xzf purge-old-kernels.tgz
 +# rm purge-old-kernels.tgz
 +</​code>​
 +
 +  * WOL Problem: <​code>​
 +# aptitude install upstart-sysv OR ... binary copy:
 +# rm /​sbin/​reboot
 +# rm /​sbin/​poweroff
 +# rm /sbin/halt
 +# cp reboot /sbin/
 +# ln -s /​sbin/​reboot /sbin/halt
 +# ln -s /​sbin/​reboot /​sbin/​poweroff
 +
 +# nano /​etc/​default/​halt
 +NETDOWN="​no"​
 +
 +# ethtool -s enp2s0 wol g
 +
 +# nmcli con modify Kabelnetzwerkverbindung\ 1 802-3-ethernet.wake-on-lan magic
 +</​code>​
 +  * nmcli Befehl erzeugt/​verändert:​ <code none /​etc/​NetworkManager/​system-connections/​Kabelnetzwerkverbindung\ 1>
 +[connection]
 +id=Kabelnetzwerkverbindung 1
 +uuid=e048d464-46cc-450b-9394-de9fb9ca759a
 +type=ethernet
 +autoconnect-priority=-999
 +permissions=
 +secondaries=
 +timestamp=1461827996
 +
 +[ethernet]
 +mac-address=xx:​xx:​xx:​xx:​xx:​xx
 +mac-address-blacklist=
 +wake-on-lan=64
 +
 +[ipv4]
 +dns-search=
 +method=auto
 +
 +[ipv6]
 +addr-gen-mode=stable-privacy
 +dns-search=
 +method=auto
 +</​code>​
 +
 +  * offlineuser <​code>​
 +linuxmuster-client/​ubuntu1604/​common/​root/​linuxmuster-client-offline-setup einmalig
 +linuxmuster-client/​ubuntu1604/​common/​root/​linuxmuster-client-offlinecheck
 +linuxmuster-client/​ubuntu1604/​common/​etc/​systemd/​system/​lightdm.service.d/​override.conf
 +linuxmuster-client/​ubuntu1604/​common/​etc/​lightdm/​lightdm.conf.d/​10-check-offline.conf
 +linuxmuster-client/​ubuntu1604/​common/​etc/​linuxmuster-client/​offlinecheck/​50-autologin.conf
 +linuxmuster-client/​ubuntu1604/​common/​etc/​linuxmuster-client/​offlinecheck/​config
 +linuxmuster-client/​ubuntu1604/​common/​etc/​linuxmuster-client/​offlinecheck/​nsswitch.conf.offline
 +linuxmuster-client/​ubuntu1604/​common/​etc/​linuxmuster-client/​offlinecheck/​nsswitch.conf.online
 +</​code>​
 +
 +
 +====== Login von extern ======
 +<​code>​
 +ECDSA key fingerprint is da:​24:​d4:​a7:​d3:​e2:​40:​74:​39:​97:​7b:​b8:​14:​0e:​af:​3f
 +</​code>​
 +
 +====== Mate Konfiguration ======
 +
 +Im Kontext des Linuxadmins muss ''​gsettings''​ ausgeführt werden. Wenn man nicht den linuxadmin anmelden will, dennoch für ihn änderungen machen will, geht auch: ''​su - linuxadmin; dbus-launch gsettings ...''​
 +
 +
 +  * Bildschirmschoner - komplett abschalten ausschalten <​code>​
 +gsettings set org.mate.screensaver idle-activation-enabled false
 +</​code>​
 +  * Bildschirmschoner - locking ausschalten <​code>​
 +gsettings set org.mate.screensaver lock-enabled false
 +</​code>​
 +  * Power butten - bei Knopfdruck nichts tun <​code>​
 +gsettings set org.mate.power-manager button-power nothing
 +</​code>​
 +  * User switching abstellen <​code>​
 +gsettings set org.mate.lockdown disable-user-switching true
 +</​code>​
 +  * Lock screen abschalten <​code>​
 +gsettings set org.mate.lockdown disable-lock-screen true
 +</​code>​
 +  * Panel konfiguration oben ist umständlich über die Konsole, denn <​code>​
 +gsettings get org.mate.panel object-id-list
 +['​menu-bar',​ '​firefox',​ '​notification-area',​ '​clock',​ '​shutdown',​ '​object-0'​]
 +</​code>​ und aus dconf-editor:​ "Eine Liste der Leistenobjektkennungen. Jede Kennung entspricht einem Leistenobjekt (z.B. einem Starter oder einer Menüleiste). Die   ​Einstellungen jedes dieser Leistenobjektes werden unter »/​apps/​panel/​objects/​$(id)« abgelegt. "
 +  * Welcome screen abschalten <​code>​
 +# rm /​etc/​skel/​.config/​autostart/​Ubuntu-mate-welcome.desktop
 +</​code>​
 +
 +  * tilda autostart abschalten, da Benutzer, die ''/​bin/​false''​ als shell haben 30 sek. nach Login nichts tun können, weil tilda das System aufhängt. <​code>​
 +# rm /​usr/​share/​mate/​autostart/​tilda.desktop
 +</​code>​
 +  * deja-dup Meldungen abschalten <​code>​
 +gsettings set org.gnome.DejaDup prompt-check disabled
 +</​code>​ oder noch besser deja-dup deinstallieren?​ -> noch besser deja-dup in ''/​home/​linuxadmin/​.config/​autostart/''​ legen und mit ''​ X-MATE-Autostart-enabled=false''​ ergänzen
 +  * X-MATE-Autostart-enabled=false
 +    * /​home/​linuxadmin/​.config/​autostart/​deja-dup-monitor.desktop => unnötig
 +    * /​home/​linuxadmin/​.config/​autostart/​sshplus.py.desktop => brauch ich hier nicht
 +    * /​home/​linuxadmin/​.config/​autostart/​blueman.desktop ​  => blueman-applet abschalten, da es abstürzt (Stand: 1.2.2016) ​
 +====== Andere Konfigurationen ======
 +  * vlc <​code>​
 +# mkdir -p /​home/​linuxadmin/​.config/​vlc
 +# cat << EOF > /​home/​linuxadmin/​.config/​vlc/​vlcrc
 +[qt4]
 +qt-privacy-ask=0
 +[core]
 +metadata-network-access=0
 +EOF
 +# chown linuxadmin:​linuxadmin /​home/​linuxadmin/​.config/​vlc/​ -R
 +</​code>​
 +  * google-chrome:​ Anpassungen manuell <​code>​
 +# rsync -avP .config/​google-chrome/​ /​home/​linuxadmin/​.config/​google-chrome/​
 +# chown linuxadmin:​linuxadmin /​home/​linuxadmin/​.config/​google-chrome/​ -R
 +</​code>​
 +====== chronologische Änderungen ======
 +  * User: "​tmpadmin:​linuxmuster"​ erstellt um X-Login zu testen... in gruppen: ''​adm cdrom sudo dip plugdev lpadmin sambashare''​
 +  * upgrade 26.01.2016 <​code>​
 +# aptitude full-upgrade
 +removes:
 +gnome-control-center-shared-data
 +libperl5.20 ​                    
 +perl-modules
 +</​code>​
 +  * reboot mit neuem Kernel
 +  * alte Kernel löschen (siehe [[anwenderwiki:​server:​alte-kernel-loeschen]])<​code>​
 +# /​root/​purge-old-kernels --keep 0
 +</​code>​
 +  * upgrade 5.2.2016 <​code>​
 +# aptitude full-upgrade
 +# /​root/​purge-old-kernels --keep 0
 +</​code>​
 +
 +====== Deinstallationen fürs Abitur ======
 +<​code>​
 +# aptitude purge oracle-java8-installer oracle-java8-set-default greenfoot
 +# aptitude --purge-unused purge libreoffice-core libreoffice-avmedia-backend-gstreamer libreoffice-base-core libreoffice-calc libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-gtk3 libreoffice-help-de libreoffice-help-en-us libreoffice-impress libreoffice-math libreoffice-ogltrans libreoffice-pdfimport libreoffice-writer mythes-de mythes-en-us libreoffice-impress libreoffice-writer ubuntu-mate-desktop ubuntu-mate-libreoffice-draw-icons ubuntu-mate-libreoffice-math-icons hyphen-de hyphen-en-us
 +# aptitude purge libreoffice-common libreoffice-style-galaxy libreoffice-style-human libreoffice-style-tango
 +# aptitude --purge-unused purge geogebra5 geogebra wxmaxima maxima
 +# aptitude --purge-unused purge scratch gchempaint firefox hexchat ubuntu-mate-core hexchat-common
 +# aptitude --purge-unused purge chromium-browser chromium-codecs-ffmpe-extra ​ gimp-help-de ubuntu-restricted-addons
 +# aptitude purge pidgin pidgin-data pidgin-libnotify pidgin-otr
 +# aptitude purge thunderbird thunderbird-locale-de thunderbird-locale-en thunderbird-locale-en-us xul-ext-gdata-provider xul-ext-lightning
 +# aptitude purge transmission-common transmission-gtk
 +# aptitude --purge-unused purge gcc-5 gcc blender inkscape librecad-data blender-data eclipse-cdt eclipse-platform-data eclipse-jdt bluej  eclipse-emf eclipse-gef eclipse-platform eclipse-pydev eclipse-pydev-data eclipse-rcp eclipse-wtp eclipse-wtp-webtools eclipse-wtp-xmltools eclipse-xsd librecad
 +# aptitude --purge-unused purge freepats git vlc-data vlc openjdk-8-jre-headless ​ default-jre-headless libvlc5 libvlccore8 vlc-nox vlc-plugin-notify libwildmidi-config gstreamer0.10-plugins-bad gstreamer1.0-plugins-bad libwildmidi1
 +</​code>​
 [[anwenderwiki:linuxclient:xenialmate]] anwenderwiki/linuxclient/xenialmate.txt · Zuletzt geändert: 2017/03/01 11:23 (Externe Bearbeitung)